Mandrake Linux Security Advisory : cups (MDKSA-2007:204-1)

This script is Copyright (C) 2007-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Alin Rad Pop of Secunia Research discovered a vulnerability in CUPS
that can be exploited by malicious individuals to execute arbitrary
code. This flaw is due to a boundary error when processing IPP
(Internet Printing Protocol) tags.

Update :

Due to incorrect build requirements/conflicts, the cups-config in
Mandriva Linux 2008.0 was displaying the full CFLAGS and libs instead
of just the libraries when 'cups-config --libs' was invoked. This
update corrects the cups-config behaviour.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 27615 (mandrake_MDKSA-2007-204.nasl)

Bugtraq ID:

CVE ID: CVE-2007-4351

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now