CVE-2007-4351

HIGH

Description

Off-by-one error in the ippReadIO function in cups/ipp.c in CUPS 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted (1) textWithLanguage or (2) nameWithLanguage Internet Printing Protocol (IPP) tag, leading to a stack-based buffer overflow.

References

http://docs.info.apple.com/article.html?artnum=307179

http://lists.apple.com/archives/security-announce/2007/Dec/msg00002.html

http://secunia.com/advisories/27233

http://secunia.com/advisories/27410

http://secunia.com/advisories/27445

http://secunia.com/advisories/27447

http://secunia.com/advisories/27474

http://secunia.com/advisories/27494

http://secunia.com/advisories/27499

http://secunia.com/advisories/27540

http://secunia.com/advisories/27577

http://secunia.com/advisories/27604

http://secunia.com/advisories/27712

http://secunia.com/advisories/28136

http://secunia.com/advisories/30847

http://secunia.com/secunia_research/2007-76/advisory/

http://security.gentoo.org/glsa/glsa-200711-16.xml

http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.501902

http://support.avaya.com/elmodocs2/security/ASA-2007-476.htm

http://www.cisco.com/en/US/products/products_security_response09186a00809a1f11.html

http://www.cups.org/str.php?L2561

http://www.debian.org/security/2007/dsa-1407

http://www.kb.cert.org/vuls/id/446897

http://www.mandriva.com/security/advisories?name=MDKSA-2007:204

http://www.novell.com/linux/security/advisories/2007_58_cups.html

http://www.redhat.com/support/errata/RHSA-2007-1020.html

http://www.redhat.com/support/errata/RHSA-2007-1022.html

http://www.redhat.com/support/errata/RHSA-2007-1023.html

http://www.securityfocus.com/bid/26268

http://www.securitytracker.com/id?1018879

http://www.us-cert.gov/cas/techalerts/TA07-352A.html

http://www.vupen.com/english/advisories/2007/3681

http://www.vupen.com/english/advisories/2007/4238

http://www.vupen.com/english/advisories/2008/1934/references

https://bugzilla.redhat.com/show_bug.cgi?id=361661

https://exchange.xforce.ibmcloud.com/vulnerabilities/38190

https://issues.rpath.com/browse/RPL-1875

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10604

https://usn.ubuntu.com/539-1/

https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00012.html

Details

Source: MITRE

Published: 2007-10-31

Updated: 2018-10-03

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH