openSUSE 10 Security Update : spamassassin (spamassassin-3077)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This upgrade brings spamassassin to version 3.1.8 with following
changes :

- fix for CVE-2007-0451: possible DoS due to incredibly
long URIs found in the message content.

- disable perl module usage in update channels unless

--allowplugins is specified

- files with names starting/ending in whitespace weren't
usable

- remove Text::Wrap related code due to upstream issues

- update spamassassin and sa-learn to better deal with
STDIN

- improvements and bug fixes related to DomainKeys and
DKIM support

- several updates for Received header parsing

- several documentation updates and random taint-variable
related issues

This update also adds some missing dependencies.

Solution :

Update the affected spamassassin packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 27451 ()

Bugtraq ID:

CVE ID: CVE-2007-0451

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now