Winamp < 5.5 FLAC Plug-in Multiple Buffer Overflows

This script is Copyright (C) 2007-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
affected by multiple buffer overflow vulnerabilities.

Description :

The remote host is using Winamp, a popular media player for Windows.

The version of Winamp installed on the remote Windows host contains a
plug-in to handle playing FLAC files that contains several integer
buffer overflow vulnerabilities. If an attacker can trick a user on
the affected host into opening a specially crafted FLAC file, he may
be able to leverage this issue to execute arbitrary code on the host
subject to the user's privileges.

See also :

http://www.nessus.org/u?674b263e
http://www.securityfocus.com/archive/1/482115/30/0/threaded
http://www.winamp.com/player/version-history
http://forums.winamp.com/showthread.php?threadid=278538

Solution :

Either upgrade to Winamp version 5.5 or later or remove the FLAC Input
Plug-in (in_flac.dll).

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 27040 ()

Bugtraq ID: 26042

CVE ID: CVE-2007-4619

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now