lighttpd mod_fastcgi HTTP Request Header Remote Overflow

This script is Copyright (C) 2007-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by a buffer overflow vulnerability.

Description :

The remote web server appears to be lighttpd running with the FastCGI
module (mod_fastcgi). The version of the FastCGI module on the remote
host is affected by a buffer overflow vulnerability. A remote attacker
can exploit this, by sending a specially crafted request with a long
header, to add or replace headers passed to PHP, such as
SCRIPT_FILENAME, which in turn could result in arbitrary code

See also :

Solution :

Upgrade to lighttpd version 1.4.18 or later. Alternatively, disable
the FastCGI module.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 26057 (lighttpd_fastcgi_overflow.nasl)

Bugtraq ID: 25622

CVE ID: CVE-2007-4727

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now