OpenOffice < 2.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2006-2016 Tenable Network Security, Inc.


Synopsis :

Arbitrary code can be executed on the remote host through OpenOffice.org.

Description :

The remote host is running a version of OpenOffice.org which is older than
version 2.0.3.

An attacker may use this to execute arbitrary code on this host.

To succeed, the attacker would have to send a rogue file to a user of the
remote computer and have him open it. The file could be crafted in such a
way that it could exploit a buffer overflow in OpenOffice.org's XML parser,
or by containing rogue macros.

See also :

http://www.openoffice.org/security/cves/CVE-2006-2199.html
http://www.openoffice.org/security/cves/CVE-2006-2198.html
http://www.openoffice.org/security/cves/CVE-2006-3117.html

Solution :

Upgrade to OpenOffice.org 2.0.3 or newer.

Risk factor :

High / CVSS Base Score : 7.6
(CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 21784 ()

Bugtraq ID: 18737
18738
18739

CVE ID: CVE-2006-3117
CVE-2006-2198
CVE-2006-2199

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now