FreeBSD : up-imapproxy -- multiple vulnerabilities (927743d4-5ca9-11d9-a9e7-0001020eed82)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Timo Sirainen reports :

There are various bugs in up-imapproxy which can crash it. Since
up-imapproxy runs in a single process with each connection handled in
a separate thread, any crash kills all the connections and stops
listening for new ones.

In 64bit systems it might be possible to make it leak data (mails,
passwords, ..) from other connections to attacker's connection.
However I don't think up-imapproxy actually works in any 64bit system
so this is just a theoretical problem.

See also :

http://marc.info/?l=bugtraq&m=109995749510773
http://www.nessus.org/u?13f720ec

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)
CVSS Temporal Score : 5.2
(CVSS2#E:U/RL:W/RC:ND)
Public Exploit Available : false

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 19033 (freebsd_pkg_927743d45ca911d9a9e70001020eed82.nasl)

Bugtraq ID: 11630

CVE ID: CVE-2004-1035

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now