FreeBSD : kdelibs -- kimgio input validation errors (06404241-b306-11d9-a788-0001020eed82)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

A KDE Security Advisory reports :

kimgio contains a PCX image file format reader that does not properly
perform input validation. A source code audit performed by the KDE
security team discovered several vulnerabilities in the PCX and other
image file format readers, some of them exploitable to execute
arbitrary code.

Impact: Remotely supplied, specially crafted image files can be used
to execute arbitrary code.

See also :

http://bugs.kde.org/102328
http://www.kde.org/info/security/advisory-20050421-1.txt
http://www.nessus.org/u?e9b66bb6

Solution :

Update the affected package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 18828 (freebsd_pkg_06404241b30611d9a7880001020eed82.nasl)

Bugtraq ID:

CVE ID: CVE-2005-1046

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now