PHP 5.1.x < 5.1.2 Multiple Vulnerabilities

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server uses a version of PHP that is affected by
multiple vulnerabilities.

Description :

According to its banner, the version of PHP 5.1.x installed on the
remote host is older than 5.1.2. Such versions may be affected by
multiple vulnerabilities :

- A format string vulnerability exists in the
error-reporting feature of the mysqli extension.

- Multiple HTTP response splitting vulnerabilities exist
that would allow remote attackers to inject arbitrary
HTTP headers via a crafted Set-Cookie header.

- Multiple cross-site scripting vulnerabilities exist when
display_errors and html_errors are on. (CVE-2006-0208)

See also :

Solution :

Upgrade to PHP version 5.1.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 17712 ()

Bugtraq ID: 16220

CVE ID: CVE-2006-0200

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now