Firefox < 0.9.3 Null Character MIME Type Spoofing Arbitrary Code Execution

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that has a code
execution vulnerability.

Description :

The installed version of Firefox is earlier than 0.9.3. Such
versions may allow arbitrary code execution.

The security vulnerability is due to the fact that Firefox stores
cached HTML documents with a known file name, and to the fact that
it's possible to force Firefox to open cached files as HTML documents
by appending a NULL byte after the file name.

A remote attacker may combine these two flaws to execute arbitrary
code on the remote host.

Solution :

Upgrade to Firefox 0.9.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 14197 ()

Bugtraq ID: 10709

CVE ID: CVE-2004-0760

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now