openSUSE Security Update : gdk-pixbuf (openSUSE-2017-1024)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for gdk-pixbuf fixes the following issues :

- CVE-2017-2862: JPEG
gdk_pixbuf__jpeg_image_load_increment Code Execution
Vulnerability (bsc#1048289)

- CVE-2017-2870: tiff_image_parse Code Execution
Vulnerability (bsc#1048544)

- CVE-2017-6313: A dangerous integer underflow in
io-icns.c (bsc#1027024)

- CVE-2017-6314: Infinite loop in io-tiff.c (bsc#1027025)

- CVE-2017-6312: Out-of-bounds read on io-ico.c
(bsc#1027026)

This update was imported from the SUSE:SLE-12-SP2:Update update
project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1027024
https://bugzilla.opensuse.org/show_bug.cgi?id=1027025
https://bugzilla.opensuse.org/show_bug.cgi?id=1027026
https://bugzilla.opensuse.org/show_bug.cgi?id=1048289
https://bugzilla.opensuse.org/show_bug.cgi?id=1048544
https://bugzilla.opensuse.org/show_bug.cgi?id=1049877

Solution :

Update the affected gdk-pixbuf packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 103160 ()

Bugtraq ID:

CVE ID: CVE-2017-2862
CVE-2017-2870
CVE-2017-6312
CVE-2017-6313
CVE-2017-6314

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now