RHEL 6 / 7 : java-1.8.0-oracle (RHSA-2017:1790)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

An update for java-1.8.0-oracle is now available for Oracle Java for
Red Hat Enterprise Linux 6 and Oracle Java for Red Hat Enterprise
Linux 7.

Red Hat Product Security has rated this update as having a security
impact of Critical. A Common Vulnerability Scoring System (CVSS) base
score, which gives a detailed severity rating, is available for each
vulnerability from the CVE link(s) in the References section.

Oracle Java SE version 8 includes the Oracle Java Runtime Environment
and the Oracle Java Software Development Kit.

This update upgrades Oracle Java SE 8 to version 8 Update 141.

Security Fix(es) :

* This update fixes multiple vulnerabilities in the Oracle Java
Runtime Environment and the Oracle Java Software Development Kit.
Further information about these flaws can be found on the Oracle Java
SE Critical Patch Update Advisory page, listed in the References
section. (CVE-2017-10053, CVE-2017-10067, CVE-2017-10074,
CVE-2017-10078, CVE-2017-10081, CVE-2017-10086, CVE-2017-10087,
CVE-2017-10089, CVE-2017-10090, CVE-2017-10096, CVE-2017-10101,
CVE-2017-10102, CVE-2017-10105, CVE-2017-10107, CVE-2017-10108,
CVE-2017-10109, CVE-2017-10110, CVE-2017-10111, CVE-2017-10114,
CVE-2017-10115, CVE-2017-10116, CVE-2017-10118, CVE-2017-10135,
CVE-2017-10176, CVE-2017-10193, CVE-2017-10198, CVE-2017-10243)

See also :

https://www.redhat.com/security/data/cve/CVE-2017-10053.html
https://www.redhat.com/security/data/cve/CVE-2017-10067.html
https://www.redhat.com/security/data/cve/CVE-2017-10074.html
https://www.redhat.com/security/data/cve/CVE-2017-10078.html
https://www.redhat.com/security/data/cve/CVE-2017-10081.html
https://www.redhat.com/security/data/cve/CVE-2017-10086.html
https://www.redhat.com/security/data/cve/CVE-2017-10087.html
https://www.redhat.com/security/data/cve/CVE-2017-10089.html
https://www.redhat.com/security/data/cve/CVE-2017-10090.html
https://www.redhat.com/security/data/cve/CVE-2017-10096.html
https://www.redhat.com/security/data/cve/CVE-2017-10101.html
https://www.redhat.com/security/data/cve/CVE-2017-10102.html
https://www.redhat.com/security/data/cve/CVE-2017-10105.html
https://www.redhat.com/security/data/cve/CVE-2017-10107.html
https://www.redhat.com/security/data/cve/CVE-2017-10108.html
https://www.redhat.com/security/data/cve/CVE-2017-10109.html
https://www.redhat.com/security/data/cve/CVE-2017-10110.html
https://www.redhat.com/security/data/cve/CVE-2017-10111.html
https://www.redhat.com/security/data/cve/CVE-2017-10114.html
https://www.redhat.com/security/data/cve/CVE-2017-10115.html
https://www.redhat.com/security/data/cve/CVE-2017-10116.html
https://www.redhat.com/security/data/cve/CVE-2017-10118.html
https://www.redhat.com/security/data/cve/CVE-2017-10135.html
https://www.redhat.com/security/data/cve/CVE-2017-10176.html
https://www.redhat.com/security/data/cve/CVE-2017-10193.html
https://www.redhat.com/security/data/cve/CVE-2017-10198.html
https://www.redhat.com/security/data/cve/CVE-2017-10243.html
http://www.nessus.org/u?52fa962b
http://www.nessus.org/u?755142b1
http://rhn.redhat.com/errata/RHSA-2017-1790.html

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false