CVE-2017-10116

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Vulnerability in the Java SE, Java SE Embedded, JRockit component of Oracle Java SE (subcomponent: Security). Supported versions that are affected are Java SE: 6u151, 7u141 and 8u131; Java SE Embedded: 8u131; JRockit: R28.3.14. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded, JRockit. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, JRockit, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded, JRockit. Note: This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.0 Base Score 8.3 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).

References

http://www.debian.org/security/2017/dsa-3919

http://www.debian.org/security/2017/dsa-3954

http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html

http://www.securityfocus.com/bid/99734

http://www.securitytracker.com/id/1038931

https://access.redhat.com/errata/RHSA-2017:1789

https://access.redhat.com/errata/RHSA-2017:1790

https://access.redhat.com/errata/RHSA-2017:1791

https://access.redhat.com/errata/RHSA-2017:1792

https://access.redhat.com/errata/RHSA-2017:2424

https://access.redhat.com/errata/RHSA-2017:2469

https://access.redhat.com/errata/RHSA-2017:2481

https://access.redhat.com/errata/RHSA-2017:2530

https://access.redhat.com/errata/RHSA-2017:3453

https://cert.vde.com/en-us/advisories/vde-2017-002

https://security.gentoo.org/glsa/201709-22

https://security.netapp.com/advisory/ntap-20170720-0001/

Details

Source: MITRE

Published: 2017-08-08

Updated: 2020-09-08

Risk Information

CVSS v2

Base Score: 5.1

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 4.9

Severity: MEDIUM

CVSS v3

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Impact Score: 6

Exploitability Score: 1.6

Severity: HIGH

Tenable Plugins

View all (47 total)

IDNameProductFamilySeverity
127357NewStart CGSL MAIN 4.05 : java-1.7.0-openjdk Multiple Vulnerabilities (NS-SA-2019-0116)NessusNewStart CGSL Local Security Checks
critical
127348NewStart CGSL MAIN 4.05 : java-1.8.0-openjdk Multiple Vulnerabilities (NS-SA-2019-0111)NessusNewStart CGSL Local Security Checks
critical
121719Photon OS 1.0: Openjre PHSA-2017-0026NessusPhotonOS Local Security Checks
critical
121718Photon OS 1.0: Openjdk PHSA-2017-0026NessusPhotonOS Local Security Checks
critical
119221Virtuozzo 6 : java-1.7.0-openjdk / java-1.7.0-openjdk-demo / etc (VZLSA-2017-2424)NessusVirtuozzo Local Security Checks
critical
119220Virtuozzo 6 : java-1.8.0-openjdk / java-1.8.0-openjdk-debug / etc (VZLSA-2017-1789)NessusVirtuozzo Local Security Checks
critical
111875Photon OS 1.0: Openjdk / Openjre / Pycrypto / Python3 PHSA-2017-0026 (deprecated)NessusPhotonOS Local Security Checks
critical
105714openSUSE Security Update : java-1_7_0-openjdk (openSUSE-2018-14)NessusSuSE Local Security Checks
critical
105538SUSE SLED12 / SLES12 Security Update : java-1_7_0-openjdk (SUSE-SU-2018:0005-1)NessusSuSE Local Security Checks
critical
105267RHEL 6 : Satellite Server (RHSA-2017:3453)NessusRed Hat Local Security Checks
critical
103450GLSA-201709-22 : Oracle JDK/JRE, IcedTea: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
103191AIX Java Advisory : java_july2017_advisory.asc (July 2017 CPU)NessusAIX Local Security Checks
critical
103066EulerOS 2.0 SP2 : java-1.7.0-openjdk (EulerOS-SA-2017-1208)NessusHuawei Local Security Checks
critical
103065EulerOS 2.0 SP1 : java-1.7.0-openjdk (EulerOS-SA-2017-1207)NessusHuawei Local Security Checks
critical
102837SUSE SLES11 Security Update : java-1_7_1-ibm (SUSE-SU-2017:2281-1)NessusSuSE Local Security Checks
critical
102836SUSE SLES12 Security Update : java-1_7_1-ibm (SUSE-SU-2017:2280-1)NessusSuSE Local Security Checks
critical
102806Debian DLA-1073-1 : openjdk-7 security updateNessusDebian Local Security Checks
critical
102801SUSE SLES12 Security Update : java-1_8_0-ibm (SUSE-SU-2017:2263-1)NessusSuSE Local Security Checks
critical
102790Debian DSA-3954-1 : openjdk-7 - security updateNessusDebian Local Security Checks
critical
102775RHEL 6 : java-1.6.0-ibm (RHSA-2017:2530)NessusRed Hat Local Security Checks
critical
102665Scientific Linux Security Update : java-1.7.0-openjdk on SL6.x, SL7.x i386/x86_64 (20170807)NessusScientific Linux Local Security Checks
critical
102621openSUSE Security Update : java-1_8_0-openjdk (openSUSE-2017-954)NessusSuSE Local Security Checks
critical
102584Ubuntu 14.04 LTS : openjdk-7 vulnerabilities (USN-3396-1)NessusUbuntu Local Security Checks
critical
102541SUSE SLED12 / SLES12 Security Update : java-1_8_0-openjdk (SUSE-SU-2017:2175-1)NessusSuSE Local Security Checks
critical
102536RHEL 6 / 7 : java-1.7.1-ibm (RHSA-2017:2481)NessusRed Hat Local Security Checks
critical
102503CentOS 6 / 7 : java-1.7.0-openjdk (CESA-2017:2424)NessusCentOS Local Security Checks
critical
102502Amazon Linux AMI : java-1.7.0-openjdk (ALAS-2017-869)NessusAmazon Linux Local Security Checks
critical
102492RHEL 6 / 7 : java-1.8.0-ibm (RHSA-2017:2469)NessusRed Hat Local Security Checks
critical
102346Oracle Linux 6 / 7 : java-1.7.0-openjdk (ELSA-2017-2424)NessusOracle Linux Local Security Checks
critical
102250RHEL 6 / 7 : java-1.7.0-openjdk (RHSA-2017:2424)NessusRed Hat Local Security Checks
critical
102238EulerOS 2.0 SP2 : java-1.8.0-openjdk (EulerOS-SA-2017-1151)NessusHuawei Local Security Checks
critical
102237EulerOS 2.0 SP1 : java-1.8.0-openjdk (EulerOS-SA-2017-1150)NessusHuawei Local Security Checks
critical
102092Ubuntu 16.04 LTS / 17.04 : openjdk-8 regression (USN-3366-2)NessusUbuntu Local Security Checks
critical
102014Ubuntu 16.04 LTS / 17.04 : openjdk-8 vulnerabilities (USN-3366-1)NessusUbuntu Local Security Checks
critical
101984Debian DSA-3919-1 : openjdk-8 - security updateNessusDebian Local Security Checks
critical
700165Oracle Java SE 6 < Update 161 / 7 < Update 151 / 8 < Update 141 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
critical
101958Amazon Linux AMI : java-1.8.0-openjdk (ALAS-2017-860)NessusAmazon Linux Local Security Checks
critical
101906CentOS 6 / 7 : java-1.8.0-openjdk (CESA-2017:1789)NessusCentOS Local Security Checks
critical
101884Scientific Linux Security Update : java-1.8.0-openjdk on SL6.x, SL7.x i386/x86_64 (20170720)NessusScientific Linux Local Security Checks
critical
101882RHEL 6 / 7 : java-1.6.0-sun (RHSA-2017:1792)NessusRed Hat Local Security Checks
critical
101881RHEL 6 / 7 : java-1.7.0-oracle (RHSA-2017:1791)NessusRed Hat Local Security Checks
critical
101880RHEL 6 / 7 : java-1.8.0-oracle (RHSA-2017:1790)NessusRed Hat Local Security Checks
critical
101879RHEL 6 / 7 : java-1.8.0-openjdk (RHSA-2017:1789)NessusRed Hat Local Security Checks
critical
101877Oracle Linux 6 / 7 : java-1.8.0-openjdk (ELSA-2017-1789)NessusOracle Linux Local Security Checks
critical
101844Oracle Java SE Multiple Vulnerabilities (July 2017 CPU) (Unix)NessusMisc.
critical
101843Oracle Java SE Multiple Vulnerabilities (July 2017 CPU)NessusWindows
critical
101839Oracle JRockit R28.3.14 Multiple Vulnerabilities (July 2017 CPU)NessusWindows
medium