Adobe Flash Player <= 25.0.0.171 Multiple Vulnerabilities (APSB17-17)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Windows host
is equal or prior to version 25.0.0.171. It is, therefore, affected by
multiple vulnerabilities :

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-3075, CVE-2017-3081, CVE-2017-3083,
CVE-2017-3084)

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-3076, CVE-2017-3077, CVE-2017-3078,
CVE-2017-3079, CVE-2017-3082)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-17.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 26.0.0.126 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now