openSUSE Security Update : libxml2 (openSUSE-2017-663)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for libxml2 fixes the following issues :

- CVE-2017-9047, CVE-2017-9048: The function
xmlSnprintfElementContent in valid.c was vulnerable to a
stack-based buffer overflow (bsc#1039063, bsc#1039064)

- CVE-2017-9049: The function xmlDictComputeFastKey in
dict.c was vulnerable to a heap-based buffer over-read.
(bsc#1039066)

- CVE-2017-9050: The function xmlDictAddString was
vulnerable to a heap-based buffer over-read
(bsc#1039661)

- CVE-2016-1839: heap-based buffer overflow
(xmlDictAddString func) (bnc#1039069)

This update was imported from the SUSE:SLE-12-SP2:Update update
project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1039063
https://bugzilla.opensuse.org/show_bug.cgi?id=1039064
https://bugzilla.opensuse.org/show_bug.cgi?id=1039066
https://bugzilla.opensuse.org/show_bug.cgi?id=1039069
https://bugzilla.opensuse.org/show_bug.cgi?id=1039661
https://bugzilla.opensuse.org/show_bug.cgi?id=981114

Solution :

Update the affected libxml2 packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 100708 ()

Bugtraq ID:

CVE ID: CVE-2016-1839
CVE-2017-9047
CVE-2017-9048
CVE-2017-9049
CVE-2017-9050

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now