ImageMagick < 6.8.8-5 Multiple PSD Handling Buffer Overflows

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains an application that is affected by a
multiple buffer overflow vulnerabilities.

Description :

The remote Windows host is running a version of ImageMagick prior to
version 6.8.8-5. It is, therefore, affected by the following
vulnerabilities :

- A buffer overflow error exists related to PSD image
file handling and the 'DecodePSDPixels' function.

- A buffer overflow error exists related to PDF image
file handling and RLE decoding. (CVE-2014-2030)

Exploitation of these issues could result in a denial of service or
arbitrary code execution.

See also :

Solution :

Upgrade to ImageMagick 6.8.8-5 or later.

Note that you may need to manually uninstall the vulnerable version
from the system.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.3
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 72722 ()

Bugtraq ID: 65478

CVE ID: CVE-2014-1958

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now