Echo: php-7.2: security update to 7.2.34+e1

critical Tenable Self-Hosted Container Security Plugin ID 477448

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, when using Apache and PHP-
CGI on Windows, if the system is set up to use certain code pages, Windows may use "Best-Fit" behavior to
replace characters in command line given to Win32 API functions. PHP CGI module may misinterpret those
characters as PHP options, which may allow a malicious user to pass options to PHP binary being run, and
thus reveal the source code of scripts, run arbitrary PHP code on the server, etc. (CVE-2024-4577)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2024-4577

Plugin Details

Severity: Critical

ID: 477448

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Critical

Score: 9.5

Percentile: 99.87

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2024-4577

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 6/4/2024

CISA Known Exploited Vulnerability Due Dates: 7/3/2024

Exploitable With

Core Impact

Metasploit (PHP CGI Argument Injection Remote Code Execution)

Reference Information

CVE: CVE-2024-4577