Echo: php-7.2: security update to 7.2.34+e1

high Tenable Self-Hosted Container Security Plugin ID 477429

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when pdo_mysql extension
with mysqlnd driver, if the third party is allowed to supply host to connect to and the password for the
connection, password of excessive length can trigger a buffer overflow in PHP, which can lead to a remote
code execution vulnerability. (CVE-2022-31626)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2022-31626

Plugin Details

Severity: High

ID: 477429

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 96.99

CVSS v2

Risk Factor: Medium

Base Score: 6

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSS Score Source: CVE-2022-31626

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 6/16/2022

Reference Information

CVE: CVE-2022-31626