Echo: php-7.2: security update to 7.2.34+e1

medium Tenable Cloud Security Plugin ID 477444

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using Firebird PDO
driver extension, a malicious database server could cause crashes in various database functions, such as
getAttribute(), execute(), fetch() and others by returning invalid response data that is not parsed
correctly by the driver. This can result in crashes, denial of service or potentially memory corruption.
(CVE-2021-21704)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2021-21704

Plugin Details

Severity: Medium

ID: 477444

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2021-21704

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 6/21/2021

Reference Information

CVE: CVE-2021-21704