Echo: php-7.2: security update to 7.2.34+e1

high Tenable Cloud Security Plugin ID 477431

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, when using streams with
configured proxy and "request_fulluri" option, the URI is not properly sanitized which can lead to HTTP
request smuggling and allow the attacker to use the proxy to perform arbitrary HTTP requests originating
from the server, thus potentially gaining access to resources not normally available to the external user.
(CVE-2024-11234)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2024-11234

Plugin Details

Severity: High

ID: 477431

Version: Revision 1.2

Type: Local

Published: 10/25/2026

Updated: 10/27/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 2.3

Percentile: 9.35

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2024-11234

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 10/25/2026

Reference Information

CVE: CVE-2024-11234