Echo: boost-1.69.0: security update to 1.69.0+e1boost-1.75.0: security update to 1.75.0+e1boost-1.84.0: security update to 1.84.0+e1zlib-1.2.11: security update to 1.2.11+e1

high Tenable Cloud Security Plugin ID 476164

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many
distant matches. (CVE-2018-25032)

Solution

Update the zlib-1.2.11 library and its related packages to version 1.2.11+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2018-25032

Plugin Details

Severity: High

ID: 476164

Version: Revision 1.1

Type: Local

Published: 10/19/2026

Updated: 10/19/2026

Risk Information

VPR

Risk Factor: Medium

Score: 5

Percentile: 93.99

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2018-25032

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/15/2026

Vulnerability Publication Date: 3/25/2022

Reference Information

CVE: CVE-2018-25032