CVE-2026-120597

medium

Description

A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

References

https://wordpress.org/plugins/usc-e-shop/

https://vuldb.com/vuln/429933/cti

https://vuldb.com/vuln/429933

https://vuldb.com/submit/1039186

https://vuldb.com/cve/CVE-2026-120597

https://github.com/bevennyamande/welcart-poc

https://euvd.enisa.europa.eu/vulnerability/EUVD-2026-115649

Details

Source: Mitre, NVD

Published: 2026-11-02

Updated: 2026-11-02

Risk Information

CVSS v2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Severity: Medium

CVSS v3

Base Score: 4.3

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Severity: Medium

CVSS v4

Base Score: 5.3

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Severity: Medium