A vulnerability has been found in Ollama up to 0.34.1. The affected element is the function IsValid of the file types/model/name.go of the component Pull API. The manipulation leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.34.2 is sufficient to fix this issue. The identifier of the patch is dfabde4539e42ba1e1eab50a3a50b88aea7958a0. It is suggested to upgrade the affected component.
https://vuldb.com/vuln/416610/cti
https://vuldb.com/submit/972855
https://vuldb.com/cve/CVE-2026-108836
https://github.com/ollama/ollama/releases/tag/v0.34.2
https://github.com/ollama/ollama/pull/18512
https://github.com/ollama/ollama/commit/dfabde4539e42ba1e1eab50a3a50b88aea7958a0
https://github.com/ollama/ollama/
https://github.com/aLtEr6/test/blob/main/test.pdf
Published: 2026-10-12
Updated: 2026-10-13
Base Score: 7.5
Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P
Severity: High
Base Score: 7.3
Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Severity: High
Base Score: 6.9
Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Severity: Medium
EPSS: 0.00466