CVE-2023-41053

low

Description

Redis is an in-memory database that persists on disk. Redis does not correctly identify keys accessed by `SORT_RO` and as a result may grant users executing this command access to keys that are not explicitly authorized by the ACL configuration. The problem exists in Redis 7.0 or newer and has been fixed in Redis 7.0.13 and 7.2.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

References

https://github.com/redis/redis/commit/9e505e6cd842338424e05883521ca1fb7d0f47f6

https://github.com/redis/redis/security/advisories/GHSA-q4jr-5p56-4xwc

https://lists.fedoraproject.org/archives/list/[email protected]/message/OLBPIUUD273UGRN2WAYHPVUAULY36QVL/

https://lists.fedoraproject.org/archives/list/[email protected]/message/UA4MSJ623BH6HP5UHSJD2FOTN3QM5DQS/

https://lists.fedoraproject.org/archives/list/[email protected]/message/YLYNYT52EHR63E7L7SHRTHEPUMAFFDLX/

Details

Source: Mitre, NVD

Published: 2023-09-06

CVSS v3

Base Score: 3.3

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Severity: Low