CVE-2022-42247

medium

Description

pfSense v2.5.2 was discovered to contain a cross-site scripting (XSS) vulnerability in the browser.php component. This vulnerability allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into a file name.

References

https://github.com/pfsense/pfsense/commit/73ca6743954ac9f35ca293e3f2af63eac20cf32e

https://gist.github.com/enferas/b4ca7a4fb52e1b5e698f87e4d655a70a

Details

Source: MITRE

Published: 2022-10-03

Updated: 2022-10-05

Type: CWE-79