CVE-2022-40960

medium

Description

Concurrent use of the URL parser with non-UTF-8 data was not thread-safe. This could lead to a use-after-free causing a potentially exploitable crash. This vulnerability affects Firefox ESR < 102.3, Thunderbird < 102.3, and Firefox < 105.

References

https://www.mozilla.org/security/advisories/mfsa2022-42/

https://www.mozilla.org/security/advisories/mfsa2022-41/

https://www.mozilla.org/security/advisories/mfsa2022-40/

https://bugzilla.mozilla.org/show_bug.cgi?id=1787633

Details

Source: MITRE

Published: 2022-12-22

Updated: 2023-01-04

Type: CWE-416