CVE-2022-3916

medium

Description

A flaw was found in the offline_access scope in Keycloak. This issue would affect users of shared computers more (especially if cookies are not cleared), due to a lack of root session validation, and the reuse of session ids across root and user authentication sessions. This enables an attacker to resolve a user session attached to a previously authenticated user; when utilizing the refresh token, they will be issued a token for the original user.

References

https://access.redhat.com/errata/RHSA-2022:8961

https://access.redhat.com/errata/RHSA-2022:8962

https://access.redhat.com/errata/RHSA-2022:8963

https://access.redhat.com/errata/RHSA-2022:8964

https://access.redhat.com/errata/RHSA-2022:8965

https://access.redhat.com/errata/RHSA-2023:1043

https://access.redhat.com/errata/RHSA-2023:1044

https://access.redhat.com/errata/RHSA-2023:1045

https://access.redhat.com/errata/RHSA-2023:1047

https://access.redhat.com/errata/RHSA-2023:1049

https://access.redhat.com/security/cve/CVE-2022-3916

https://bugzilla.redhat.com/show_bug.cgi?id=2141404

Details

Source: Mitre, NVD

Published: 2023-09-20

CVSS v3

Base Score: 6.8

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Severity: Medium