CVE-2022-3144

medium

Description

The Wordfence Security – Firewall & Malware Scan plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to and including 7.6.0 via a setting on the options page due to insufficient escaping on the stored value. This makes it possible for authenticated users, with administrative privileges, to inject malicious web scripts into the setting that executes whenever a user accesses a page displaying the affected setting on sites running a vulnerable version.

References

https://www.wordfence.com/vulnerability-advisories/#CVE-2022-3144

https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2780937%40wordfence&new=2780937%40wordfence&sfp_email=&sfph_mail=

https://wordpress.org/plugins/wordfence/#developers

Details

Source: MITRE

Published: 2022-09-23

Updated: 2022-09-23

Type: CWE-79