CVE-2022-30950

high

Description

Jenkins WMI Windows Agents Plugin 1.8 and earlier includes the Windows Remote Command library which has a buffer overflow vulnerability that may allow users able to connect to a named pipe to execute commands on the Windows agent machine.

References

http://www.openwall.com/lists/oss-security/2022/05/17/8

https://www.jenkins.io/security/advisory/2022-05-17/#SECURITY-2604

Details

Source: MITRE

Published: 2022-05-17

Updated: 2022-05-26

Type: CWE-120

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH