CVE-2022-30632

high

Description

Uncontrolled recursion in Glob in path/filepath before Go 1.17.12 and Go 1.18.4 allows an attacker to cause a panic due to stack exhaustion via a path containing a large number of path separators.

References

https://go.dev/issue/53416

https://groups.google.com/g/golang-announce/c/nqrv9fbR0zE

https://pkg.go.dev/vuln/GO-2022-0522

https://go.dev/cl/417066

https://go.googlesource.com/go/+/ac68c6c683409f98250d34ad282b9e1b0c9095ef

https://lists.fedoraproject.org/archives/list/[email protected]/message/RQXU752ALW53OJAF5MG3WMR5CCZVLWW6/

Details

Source: MITRE

Published: 2022-08-10

Updated: 2022-10-25

Type: CWE-674