CVE-2022-29221

high

Description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.

References

https://github.com/smarty-php/smarty/releases/tag/v3.1.45

https://github.com/smarty-php/smarty/security/advisories/GHSA-634x-pc3q-cf4c

https://github.com/smarty-php/smarty/commit/64ad6442ca1da31cefdab5c9874262b702cccddd

https://github.com/smarty-php/smarty/releases/tag/v4.1.1

https://www.debian.org/security/2022/dsa-5151

https://lists.debian.org/debian-lts-announce/2022/05/msg00044.html

https://security.gentoo.org/glsa/202209-09

Details

Source: MITRE

Published: 2022-05-24

Updated: 2022-09-25

Type: CWE-94

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH