CVE-2022-27774

medium

Description

An insufficiently protected credentials vulnerability exists in curl 4.9 to and include curl 7.82.0 are affected that could allow an attacker to extract credentials when follows HTTP(S) redirects is used with authentication could leak credentials to other services that exist on different protocols or port numbers.

References

https://hackerone.com/reports/1543773

https://security.netapp.com/advisory/ntap-20220609-0008/

https://www.debian.org/security/2022/dsa-5197

Details

Source: MITRE

Published: 2022-06-02

Updated: 2022-08-02

Type: CWE-522

Risk Information

CVSS v2

Base Score: 3.5

Vector: AV:N/AC:M/Au:S/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 6.8

Severity: LOW

CVSS v3

Base Score: 5.7

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 2.1

Severity: MEDIUM