CVE-2022-2227

medium

Description

Improper access control in the runner jobs API in GitLab CE/EE affecting all versions prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows a previous maintainer of a project with a specific runner to access job and project meta data under certain conditions

References

https://hackerone.com/reports/1092199

https://gitlab.com/gitlab-org/gitlab/-/issues/300842

https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2227.json

Details

Source: MITRE

Published: 2022-07-01

Updated: 2022-07-08

Type: CWE-732

Risk Information

CVSS v2

Base Score: 3.5

Vector: AV:N/AC:M/Au:S/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 6.8

Severity: LOW

CVSS v3

Base Score: 4.3

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Impact Score: 1.4

Exploitability Score: 2.8

Severity: MEDIUM