CVE-2022-2185

high

Description

A critical issue has been discovered in GitLab affecting all versions starting from 14.0 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 where an authenticated user authorized to import projects could import a maliciously crafted project leading to remote code execution.

References

https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2185.json

https://hackerone.com/reports/1609965

https://gitlab.com/gitlab-org/gitlab/-/issues/366088

Details

Source: MITRE

Published: 2022-07-01

Updated: 2022-10-29

Type: CWE-732

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH