CVE-2021-4178

medium

Description

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

References

https://bugzilla.redhat.com/show_bug.cgi?id=2034388

https://access.redhat.com/security/cve/CVE-2021-4178

https://github.com/fabric8io/kubernetes-client/issues/3653

https://github.com/advisories/GHSA-98g7-rxmf-rrxm

Details

Source: MITRE

Published: 2022-08-24

Updated: 2022-10-04

Type: CWE-502