CVE-2021-39909

medium

Description

Lack of email address ownership verification in the CODEOWNERS feature in all versions of GitLab EE starting from 11.3 before 14.2.6, all versions starting from 14.3 before 14.3.4, and all versions starting from 14.4 before 14.4.1 allows an attacker to bypass CODEOWNERS Merge Request approval requirement under rare circumstances

References

https://hackerone.com/reports/1237750

https://gitlab.com/gitlab-org/gitlab/-/issues/335191

https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39909.json

Details

Source: MITRE

Published: 2021-11-05

Updated: 2022-05-13

Type: CWE-347

Risk Information

CVSS v2

Base Score: 3.5

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 6.8

Severity: LOW

CVSS v3

Base Score: 5.3

Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N

Impact Score: 3.6

Exploitability Score: 1.6

Severity: MEDIUM