CVE-2021-3875

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

vim is vulnerable to Heap-based Buffer Overflow

References

https://huntr.dev/bounties/5cdbc168-6ba1-4bc2-ba6c-28be12166a53

https://github.com/vim/vim/commit/35a319b77f897744eec1155b736e9372c9c5575f

https://lists.fedoraproject.org/archives/list/[email protected]/message/S42L4Z4DTW4LHLQ4FJ33VEOXRCBE7WN4/

https://lists.fedoraproject.org/archives/list/[email protected]/message/7K4JJBIH3OQSZRVTWKCJCDLGMFGQ5DOH/

Details

Source: MITRE

Published: 2021-10-15

Updated: 2021-11-24

Type: CWE-122

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM