CVE-2021-3711

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt(). Typically an application will call this function twice. The first time, on entry, the "out" parameter can be NULL and, on exit, the "outlen" parameter is populated with the buffer size required to hold the decrypted plaintext. The application can then allocate a sufficiently sized buffer and call EVP_PKEY_decrypt() again, but this time passing a non-NULL value for the "out" parameter. A bug in the implementation of the SM2 decryption code means that the calculation of the buffer size required to hold the plaintext returned by the first call to EVP_PKEY_decrypt() can be smaller than the actual size required by the second call. This can lead to a buffer overflow when EVP_PKEY_decrypt() is called by the application a second time with a buffer that is too small. A malicious attacker who is able present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated. Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k).

References

https://www.openssl.org/news/secadv/20210824.txt

https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=59f5e75f3bced8fc0e130d72a3f582cf7b480b46

https://www.debian.org/security/2021/dsa-4963

https://lists.apache.org/thread.html/[email protected]%3Cdev.tomcat.apache.org%3E

http://www.openwall.com/lists/oss-security/2021/08/26/2

https://lists.apache.org/thread.html/[email protected]%3Cdev.tomcat.apache.org%3E

https://security.netapp.com/advisory/ntap-20210827-0010/

https://www.tenable.com/security/tns-2021-16

https://www.oracle.com/security-alerts/cpuoct2021.html

https://security.netapp.com/advisory/ntap-20211022-0003/

Details

Source: MITRE

Published: 2021-08-24

Updated: 2021-12-02

Type: CWE-120

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
155533EulerOS Virtualization 2.9.0 : openssl (EulerOS-SA-2021-2770)NessusHuawei Local Security Checks
critical
155478EulerOS Virtualization 2.9.1 : openssl (EulerOS-SA-2021-2733)NessusHuawei Local Security Checks
critical
155287EulerOS 2.0 SP5 : openssl111d (EulerOS-SA-2021-2668)NessusHuawei Local Security Checks
critical
155249EulerOS 2.0 SP9 : openssl (EulerOS-SA-2021-2717)NessusHuawei Local Security Checks
critical
155238EulerOS 2.0 SP9 : openssl (EulerOS-SA-2021-2692)NessusHuawei Local Security Checks
critical
154790EulerOS 2.0 SP8 : openssl (EulerOS-SA-2021-2639)NessusHuawei Local Security Checks
critical
154259MySQL 5.7.x < 5.7.36 Multiple Vulnerabilities (Oct 2021 CPU)NessusDatabases
critical
154258MySQL 8.0.x < 8.0.27 Multiple Vulnerabilities (Oct 2021 CPU)NessusDatabases
critical
153589Tenable SecurityCenter OpenSSL < 1.1.1l Multiple Vulnerabilities (TNS-2021-16)NessusMisc.
critical
153044Photon OS 4.0: Openssl PHSA-2021-4.0-0094NessusPhotonOS Local Security Checks
critical
152885Photon OS 3.0: Nxtgn PHSA-2021-3.0-0290NessusPhotonOS Local Security Checks
critical
152882Photon OS 2.0: Nxtgn PHSA-2021-2.0-0383NessusPhotonOS Local Security Checks
critical
152841openSUSE 15 Security Update : openssl-1_1 (openSUSE-SU-2021:1188-1)NessusSuSE Local Security Checks
high
152818FreeBSD : OpenSSL -- multiple vulnerabilities (96811d4a-04ec-11ec-9b84-d4c9ef517024)NessusFreeBSD Local Security Checks
critical
152808SUSE SLED12 / SLES12 Security Update : openssl-1_1 (SUSE-SU-2021:2833-1)NessusSuSE Local Security Checks
high
152800SUSE SLED15 / SLES15 Security Update : openssl-1_1 (SUSE-SU-2021:2830-1)NessusSuSE Local Security Checks
high
152798openSUSE 15 Security Update : openssl-1_1 (openSUSE-SU-2021:2830-1)NessusSuSE Local Security Checks
high
152784Ubuntu 18.04 LTS / 20.04 LTS / 21.04 : OpenSSL vulnerabilities (USN-5051-1)NessusUbuntu Local Security Checks
critical
152783Debian DSA-4963-1 : openssl - security updateNessusDebian Local Security Checks
high
152782OpenSSL 1.1.1 < 1.1.1l VulnerabilityNessusWeb Servers
critical