CVE-2021-3694

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

LedgerSMB does not sufficiently HTML-encode error messages sent to the browser. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

References

https://huntr.dev/bounties/ef7f4cf7-3a81-4516-b261-f5b6ac21430c

https://ledgersmb.org/cve-2021-3694-cross-site-scripting

https://github.com/ledgersmb/ledgersmb/commit/98fa476d46a4a7e5e9492ed69b4fa190be5547fc

https://www.debian.org/security/2021/dsa-4962

Details

Source: MITRE

Published: 2021-08-23

Updated: 2021-08-27

Type: CWE-79

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 9.6

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Impact Score: 6

Exploitability Score: 2.8

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.1.0 to 1.1.12 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.2.0 to 1.2.26 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.3.0 to 1.3.47 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.4.0 to 1.4.42 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.5.0 to 1.5.30 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.6.0 to 1.6.33 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.7.0 to 1.7.32 (inclusive)

cpe:2.3:a:ledgersmb:ledgersmb:*:*:*:*:*:*:*:* versions from 1.8.0 to 1.8.17 (inclusive)

Configuration 2

OR

cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*

cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*

Tenable Plugins

View all (2 total)

IDNameProductFamilySeverity
153851Ubuntu 20.04 LTS / 21.04 : LedgerSMB vulnerabilities (USN-5097-1)NessusUbuntu Local Security Checks
critical
152775Debian DSA-4962-1 : ledgersmb - security updateNessusDebian Local Security Checks
high