CVE-2021-36160

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A carefully crafted request uri-path can cause mod_proxy_uwsgi to read above the allocated memory and crash (DoS). This issue affects Apache HTTP Server versions 2.4.30 to 2.4.48 (inclusive).

References

http://httpd.apache.org/security/vulnerabilities_24.html

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.fedoraproject.org/archives/list/[email protected]/message/SPBR6WUYBJNACHKE65SPL7TJOHX7RHWD/

https://lists.apache.org/thread.html/[email protected]%3Cusers.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cusers.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cusers.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cusers.httpd.apache.org%3E

https://lists.fedoraproject.org/archives/list/[email protected]/message/ZNCYSR3BXT36FFF4XTCPL3HDQK4VP45R/

https://lists.debian.org/debian-lts-announce/2021/09/msg00016.html

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://security.netapp.com/advisory/ntap-20211008-0004/

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://www.debian.org/security/2021/dsa-4982

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cbugs.httpd.apache.org%3E

https://lists.debian.org/debian-lts-announce/2021/10/msg00016.html

Details

Source: MITRE

Published: 2021-09-16

Updated: 2021-10-20

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (13 total)

IDNameProductFamilySeverity
154188Amazon Linux AMI : httpd24 (ALAS-2021-1543)NessusAmazon Linux Local Security Checks
critical
154179Amazon Linux 2 : httpd (ALAS-2021-1716)NessusAmazon Linux Local Security Checks
critical
154067SUSE SLES15 Security Update : apache2 (SUSE-SU-2021:3335-1)NessusSuSE Local Security Checks
critical
153970Debian DSA-4982-1 : apache2 - security updateNessusDebian Local Security Checks
critical
153962Photon OS 2.0: Httpd PHSA-2021-2.0-0399NessusPhotonOS Local Security Checks
critical
153961Photon OS 3.0: Httpd PHSA-2021-3.0-0309NessusPhotonOS Local Security Checks
critical
153957Photon OS 1.0: Httpd PHSA-2021-1.0-0437NessusPhotonOS Local Security Checks
critical
153843Debian DLA-2768-1 : uwsgi - LTS security updateNessusDebian Local Security Checks
high
153816FreeBSD : Apache httpd -- multiple vulnerabilities (882a38f9-17dd-11ec-b335-d4c9ef517024)NessusFreeBSD Local Security Checks
critical
153768Ubuntu 18.04 LTS / 20.04 LTS / 21.04 : Apache HTTP Server vulnerabilities (USN-5090-1)NessusUbuntu Local Security Checks
critical
153586Apache >= 2.4.30 < 2.4.49 mod_proxy_uwsgiNessusWeb Servers
high
153456Slackware Linux 14.0 / 14.1 / 14.2 / current httpd Multiple Vulnerabilities (SSA:2021-259-01)NessusSlackware Local Security Checks
high
112981Apache 2.4.x < 2.4.49 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical