CVE-2021-3472

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A flaw was found in xorg-x11-server in versions before 1.20.11. An integer underflow can occur in xserver which can lead to a local privilege escalation. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

References

https://lists.x.org/archives/xorg-announce/2021-April/003080.html

https://seclists.org/oss-sec/2021/q2/20

https://www.zerodayinitiative.com/advisories/ZDI-21-463/

https://bugzilla.redhat.com/show_bug.cgi?id=1944167

https://www.debian.org/security/2021/dsa-4893

https://www.tenable.com/plugins/nessus/148701

http://www.openwall.com/lists/oss-security/2021/04/13/1

https://lists.fedoraproject.org/archives/list/[email protected]/message/MO6S5OPXUDYBSRSVWVLFLJ6AFERG4HNY/

https://lists.fedoraproject.org/archives/list/[email protected]/message/PEXPCLMVU25AUZTUXC4MYBGPKOAIM5TW/

https://lists.debian.org/debian-lts-announce/2021/04/msg00013.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/MDF7TAJE7NPZPNVOXSD5HBIFLNPUOD2V/

https://lists.fedoraproject.org/archives/list/[email protected]/message/N63KL3T22HNFT4FJ7VMVF6U5Q4RFJIQF/

https://gitlab.freedesktop.org/xorg/xserver/-/commit/7aaf54a1884f71dc363f0b884e57bcb67407a6cd

https://security.gentoo.org/glsa/202104-02

Details

Source: MITRE

Published: 2021-04-26

Updated: 2021-05-19

Type: CWE-191

Risk Information

CVSS v2

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (26 total)

IDNameProductFamilySeverity
153723EulerOS 2.0 SP9 : xorg-x11-server (EulerOS-SA-2021-2568)NessusHuawei Local Security Checks
high
153701EulerOS 2.0 SP9 : xorg-x11-server (EulerOS-SA-2021-2544)NessusHuawei Local Security Checks
high
153284EulerOS 2.0 SP2 : xorg-x11-server (EulerOS-SA-2021-2440)NessusHuawei Local Security Checks
high
151775EulerOS 2.0 SP5 : xorg-x11-server (EulerOS-SA-2021-2234)NessusHuawei Local Security Checks
high
151323EulerOS Virtualization for ARM 64 3.0.2.0 : xorg-x11-server (EulerOS-SA-2021-2085)NessusHuawei Local Security Checks
high
151186EulerOS Virtualization for ARM 64 3.0.6.0 : xorg-x11-server (EulerOS-SA-2021-2016)NessusHuawei Local Security Checks
high
151047EulerOS 2.0 SP8 : xorg-x11-server (EulerOS-SA-2021-1991)NessusHuawei Local Security Checks
high
150774CentOS 7 : xorg-x11-server (CESA-2021:2033)NessusCentOS Local Security Checks
high
150678SUSE SLES11 Security Update : xorg-x11-server (SUSE-SU-2021:14690-1)NessusSuSE Local Security Checks
high
149814Amazon Linux AMI : xorg-x11-server (ALAS-2021-1502)NessusAmazon Linux Local Security Checks
high
149785Oracle Linux 7 : xorg-x11-server (ELSA-2021-2033)NessusOracle Linux Local Security Checks
high
149735RHEL 7 : xorg-x11-server (RHSA-2021:2033)NessusRed Hat Local Security Checks
high
149305Amazon Linux 2 : xorg-x11-server (ALAS-2021-1633)NessusAmazon Linux Local Security Checks
high
149216GLSA-202104-02 : X.Org X Server: Privilege escalationNessusGentoo Local Security Checks
high
149138EulerOS 2.0 SP3 : xorg-x11-server (EulerOS-SA-2021-1863)NessusHuawei Local Security Checks
high
148841Debian DSA-4893-1 : xorg-server - security updateNessusDebian Local Security Checks
high
148716Fedora 33 : xorg-x11-server (2021-139f3fc21c)NessusFedora Local Security Checks
critical
148701Debian DLA-2627-1 : xorg-server security updateNessusDebian Local Security Checks
high
148696openSUSE Security Update : xorg-x11-server (openSUSE-2021-554)NessusSuSE Local Security Checks
high
148600SUSE SLES12 Security Update : xorg-x11-server (SUSE-SU-2021:1187-1)NessusSuSE Local Security Checks
high
148594SUSE SLES15 Security Update : xorg-x11-server (SUSE-SU-2021:1188-1)NessusSuSE Local Security Checks
high
148533SUSE SLES12 Security Update : xorg-x11-server (SUSE-SU-2021:1181-1)NessusSuSE Local Security Checks
high
148531SUSE SLED15 / SLES15 Security Update : xorg-x11-server (SUSE-SU-2021:1182-1)NessusSuSE Local Security Checks
high
148521SUSE SLES15 Security Update : xorg-x11-server (SUSE-SU-2021:1179-1)NessusSuSE Local Security Checks
high
148510SUSE SLES12 Security Update : xorg-x11-server (SUSE-SU-2021:1180-1)NessusSuSE Local Security Checks
high
148495Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 : X.Org X Server vulnerability (USN-4905-1)NessusUbuntu Local Security Checks
high