CVE-2021-3450

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

References

https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=2a40b7bc7b94dd7de897a74571e7024f0cf0d63b

https://www.openssl.org/news/secadv/20210325.txt

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-openssl-2021-GHY28dJd

https://security.netapp.com/advisory/ntap-20210326-0006/

https://security.FreeBSD.org/advisories/FreeBSD-SA-21:07.openssl.asc

http://www.openwall.com/lists/oss-security/2021/03/27/1

http://www.openwall.com/lists/oss-security/2021/03/27/2

http://www.openwall.com/lists/oss-security/2021/03/28/3

http://www.openwall.com/lists/oss-security/2021/03/28/4

https://security.gentoo.org/glsa/202103-03

https://www.tenable.com/security/tns-2021-05

https://lists.fedoraproject.org/archives/list/[email protected]/message/CCBFLLVQVILIVGZMBJL3IXZGKWQISYNP/

https://www.tenable.com/security/tns-2021-08

https://kc.mcafee.com/corporate/index?page=content&id=SB10356

https://mta.openssl.org/pipermail/openssl-announce/2021-March/000198.html

https://www.tenable.com/security/tns-2021-09

https://www.oracle.com/security-alerts/cpuApr2021.html

https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44845

https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0013

Details

Source: MITRE

Published: 2021-03-25

Updated: 2021-07-20

Type: CWE-295

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.4

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Impact Score: 5.2

Exploitability Score: 2.2

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:freebsd:freebsd:12.2:-:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:12.2:p1:*:*:*:*:*:*

cpe:2.3:o:freebsd:freebsd:12.2:p2:*:*:*:*:*:*

Configuration 3

AND

OR

cpe:2.3:o:netapp:santricity_smi-s_provider_firmware:-:*:*:*:*:*:*:*

OR

cpe:2.3:h:netapp:santricity_smi-s_provider:-:*:*:*:*:*:*:*

Configuration 4

AND

OR

cpe:2.3:o:netapp:storagegrid_firmware:-:*:*:*:*:*:*:*

OR

cpe:2.3:h:netapp:storagegrid:-:*:*:*:*:*:*:*

Configuration 5

OR

cpe:2.3:o:windriver:linux:-:*:*:*:cd:*:*:*

cpe:2.3:o:windriver:linux:17.0:*:*:*:lts:*:*:*

cpe:2.3:o:windriver:linux:18.0:*:*:*:lts:*:*:*

cpe:2.3:o:windriver:linux:19.0:*:*:*:lts:*:*:*

Configuration 6

OR

cpe:2.3:a:netapp:cloud_volumes_ontap_mediator:-:*:*:*:*:*:*:*

cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:*

cpe:2.3:a:netapp:ontap_select_deploy_administration_utility:-:*:*:*:*:*:*:*

cpe:2.3:a:netapp:storagegrid:-:*:*:*:*:*:*:*

Configuration 7

OR

cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*

Configuration 8

OR

cpe:2.3:a:tenable:nessus:*:*:*:*:*:*:*:* versions up to 8.13.1 (inclusive)

cpe:2.3:a:tenable:nessus_agent:*:*:*:*:*:*:*:* versions from 8.2.1 to 8.2.3 (inclusive)

cpe:2.3:a:tenable:nessus_network_monitor:5.11.0:*:*:*:*:*:*:*

cpe:2.3:a:tenable:nessus_network_monitor:5.11.1:*:*:*:*:*:*:*

cpe:2.3:a:tenable:nessus_network_monitor:5.12.0:*:*:*:*:*:*:*

cpe:2.3:a:tenable:nessus_network_monitor:5.12.1:*:*:*:*:*:*:*

cpe:2.3:a:tenable:nessus_network_monitor:5.13.0:*:*:*:*:*:*:*

Configuration 9

OR

cpe:2.3:a:oracle:graalvm:19.3.5:*:*:*:enterprise:*:*:*

cpe:2.3:a:oracle:graalvm:20.3.1.2:*:*:*:enterprise:*:*:*

cpe:2.3:a:oracle:graalvm:21.0.0.2:*:*:*:enterprise:*:*:*

cpe:2.3:a:oracle:mysql_server:*:*:*:*:*:*:*:* versions up to 5.7.33 (inclusive)

cpe:2.3:a:oracle:mysql_server:*:*:*:*:*:*:*:* versions from 8.0.15 to 8.0.23 (inclusive)

cpe:2.3:a:oracle:mysql_workbench:*:*:*:*:*:*:*:* versions up to 8.0.23 (inclusive)

cpe:2.3:a:oracle:secure_global_desktop:5.6:*:*:*:*:*:*:*

Configuration 10

OR

cpe:2.3:a:mcafee:web_gateway:8.2.19:*:*:*:*:*:*:*

cpe:2.3:a:mcafee:web_gateway:9.2.10:*:*:*:*:*:*:*

cpe:2.3:a:mcafee:web_gateway:10.1.1:*:*:*:*:*:*:*

cpe:2.3:a:mcafee:web_gateway_cloud_service:8.2.19:*:*:*:*:*:*:*

cpe:2.3:a:mcafee:web_gateway_cloud_service:9.2.10:*:*:*:*:*:*:*

cpe:2.3:a:mcafee:web_gateway_cloud_service:10.1.1:*:*:*:*:*:*:*

Tenable Plugins

View all (29 total)

IDNameProductFamilySeverity
151968MySQL 8.0.x < 8.0.26 Multiple Vulnerabilities (Jul 2021 CPU)NessusDatabases
high
151906Oracle MySQL Connectors (Jul 2021 CPU)NessusMisc.
high
151823openSUSE 15 Security Update : nodejs12 (openSUSE-SU-2021:1059-1)NessusSuSE Local Security Checks
high
151818openSUSE 15 Security Update : nodejs10 (openSUSE-SU-2021:1061-1)NessusSuSE Local Security Checks
high
151758SUSE SLES15 Security Update : nodejs10 (SUSE-SU-2021:2353-1)NessusSuSE Local Security Checks
high
151727openSUSE 15 Security Update : nodejs12 (openSUSE-SU-2021:2327-1)NessusSuSE Local Security Checks
high
151723openSUSE 15 Security Update : nodejs10 (openSUSE-SU-2021:2353-1)NessusSuSE Local Security Checks
high
151656SUSE SLES12 Security Update : nodejs10 (SUSE-SU-2021:2323-1)NessusSuSE Local Security Checks
high
151655SUSE SLES15 Security Update : nodejs12 (SUSE-SU-2021:2327-1)NessusSuSE Local Security Checks
high
149403Nessus Network Monitor < 5.13.1 Multiple Vulnerabilities (TNS-2021-09)NessusMisc.
high
148986Oracle MySQL Enterprise Monitor Multiple Vulnerabilities (Apr 2021 CPU)NessusCGI abuses
critical
148568RHEL 7 : Red Hat JBoss Core Services Apache HTTP Server 2.4.37 SP7 (RHSA-2021:1199)NessusRed Hat Local Security Checks
high
148563RHEL 7 : Red Hat JBoss Web Server 3.1 Service Pack 12 (RHSA-2021:1202)NessusRed Hat Local Security Checks
high
148562RHEL 7 / 8 : Red Hat JBoss Web Server 5.4.2 Security Update (Important) (RHSA-2021:1195)NessusRed Hat Local Security Checks
high
148547Oracle Linux 8 : openssl (ELSA-2021-1024)NessusOracle Linux Local Security Checks
high
148542RHEL 8 : Red Hat Virtualization (RHSA-2021:1189)NessusRed Hat Local Security Checks
high
148534FreeBSD : Node.js -- April 2021 Security Releases (c0c1834c-9761-11eb-acfd-0022489ad614)NessusFreeBSD Local Security Checks
high
148392Tenable Nessus Agent < 8.2.4 Multiple Vulnerabilities (TNS-2021-08)NessusMisc.
high
148355Photon OS 4.0: Openssl PHSA-2021-4.0-0007NessusPhotonOS Local Security Checks
high
148297Tenable Nessus 8.9.0 < 8.13.2 Multiple Vulnerabilities (TNS-2021-05)NessusMisc.
high
148281CentOS 8 : openssl (CESA-2021:1024)NessusCentOS Local Security Checks
high
148271GLSA-202103-03 : OpenSSL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
148259Oracle Linux 8 : openssl (ELSA-2021-9151) (deprecated)NessusOracle Linux Local Security Checks
high
148249RHEL 8 : openssl (RHSA-2021:1024)NessusRed Hat Local Security Checks
high
148200FreeBSD : OpenSSL -- Multiple vulnerabilities (5a668ab3-8d86-11eb-b8d6-d4c9ef517024)NessusFreeBSD Local Security Checks
high
148196Amazon Linux 2 : openssl11 (ALAS-2021-1622)NessusAmazon Linux Local Security Checks
high
148192Photon OS 3.0: Nxtgn PHSA-2021-3.0-0210NessusPhotonOS Local Security Checks
high
148186Photon OS 2.0: Nxtgn PHSA-2021-2.0-0331NessusPhotonOS Local Security Checks
high
148125OpenSSL 1.1.1 < 1.1.1k Multiple VulnerabilitiesNessusWeb Servers
high