CVE-2021-33560

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

References

https://dev.gnupg.org/T5466

https://dev.gnupg.org/rCe8b7f10be275bcedb5fc05ed4837a89bfd605c61

https://dev.gnupg.org/T5305

https://dev.gnupg.org/T5328

https://lists.debian.org/debian-lts-announce/2021/06/msg00021.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/R7OAPCUGPF3VLA7QAJUQSL255D4ITVTL/

https://lists.fedoraproject.org/archives/list/[email protected]/message/BKKTOIGFW2SGN3DO2UHHVZ7MJSYN4AAB/

https://www.oracle.com/security-alerts/cpuoct2021.html

Details

Source: MITRE

Published: 2021-06-08

Updated: 2021-12-01

Type: CWE-203

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (25 total)

IDNameProductFamilySeverity
156537EulerOS Virtualization 3.0.2.6 : libgcrypt (EulerOS-SA-2021-2888)NessusHuawei Local Security Checks
high
156432EulerOS 2.0 SP5 : libgcrypt (EulerOS-SA-2021-2935)NessusHuawei Local Security Checks
high
156369EulerOS Virtualization 3.0.2.0 : libgcrypt (EulerOS-SA-2021-2836)NessusHuawei Local Security Checks
high
155499EulerOS Virtualization 2.9.0 : libgcrypt (EulerOS-SA-2021-2795)NessusHuawei Local Security Checks
high
155472EulerOS Virtualization 2.9.1 : libgcrypt (EulerOS-SA-2021-2759)NessusHuawei Local Security Checks
high
155400Oracle Linux 8 : libgcrypt (ELSA-2021-4409)NessusOracle Linux Local Security Checks
high
155071RHEL 8 : libgcrypt (RHSA-2021:4409)NessusRed Hat Local Security Checks
high
155057CentOS 8 : libgcrypt (CESA-2021:4409)NessusCentOS Local Security Checks
high
154373EulerOS 2.0 SP3 : libgcrypt (EulerOS-SA-2021-2590)NessusHuawei Local Security Checks
high
153937Photon OS 4.0: Libgcrypt PHSA-2021-4.0-0051NessusPhotonOS Local Security Checks
high
153758EulerOS 2.0 SP5 : libgcrypt (EulerOS-SA-2021-2503)NessusHuawei Local Security Checks
high
153706EulerOS 2.0 SP9 : libgcrypt (EulerOS-SA-2021-2556)NessusHuawei Local Security Checks
high
153672EulerOS 2.0 SP9 : libgcrypt (EulerOS-SA-2021-2532)NessusHuawei Local Security Checks
high
153639EulerOS 2.0 SP8 : libgcrypt (EulerOS-SA-2021-2469)NessusHuawei Local Security Checks
high
153514Ubuntu 16.04 LTS : Libgcrypt vulnerabilities (USN-5080-2)NessusUbuntu Local Security Checks
high
153447Ubuntu 18.04 LTS / 20.04 LTS / 21.04 : Libgcrypt vulnerabilities (USN-5080-1)NessusUbuntu Local Security Checks
high
153300EulerOS 2.0 SP2 : libgcrypt (EulerOS-SA-2021-2395)NessusHuawei Local Security Checks
high
153185Photon OS 3.0: Libgcrypt PHSA-2021-3.0-0257NessusPhotonOS Local Security Checks
high
151750openSUSE 15 Security Update : libgcrypt (openSUSE-SU-2021:2157-1)NessusSuSE Local Security Checks
high
151109SUSE SLES15 Security Update : libgcrypt (SUSE-SU-2021:2155-1)NessusSuSE Local Security Checks
high
151102SUSE SLED12 / SLES12 Security Update : libgcrypt (SUSE-SU-2021:2156-1)NessusSuSE Local Security Checks
high
151096SUSE SLED15 / SLES15 Security Update : libgcrypt (SUSE-SU-2021:2157-1)NessusSuSE Local Security Checks
high
151070openSUSE 15 Security Update : libgcrypt (openSUSE-SU-2021:0919-1)NessusSuSE Local Security Checks
high
151006Debian DLA-2691-1 : libgcrypt20 security updateNessusDebian Local Security Checks
high
150872SUSE SLES11 Security Update : libgcrypt (SUSE-SU-2021:14751-1)NessusSuSE Local Security Checks
high