CVE-2021-33516

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in GUPnP before 1.0.7 and 1.1.x and 1.2.x before 1.2.5. It allows DNS rebinding. A remote web server can exploit this vulnerability to trick a victim's browser into triggering actions against local UPnP services implemented using this library. Depending on the affected service, this could be used for data exfiltration, data tempering, etc.

References

https://gitlab.gnome.org/GNOME/gupnp/-/issues/24

https://discourse.gnome.org/t/security-relevant-releases-for-gupnp-issue-cve-2021-33516/6536

Details

Source: MITRE

Published: 2021-05-24

Updated: 2021-05-28

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Impact Score: 5.2

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (15 total)

IDNameProductFamilySeverity
154564NewStart CGSL CORE 5.04 / MAIN 5.04 : gupnp Vulnerability (NS-SA-2021-0115)NessusNewStart CGSL Local Security Checks
high
151755openSUSE 15 Security Update : gupnp (openSUSE-SU-2021:2153-1)NessusSuSE Local Security Checks
high
151268Amazon Linux 2 : gupnp (ALAS-2021-1673)NessusAmazon Linux Local Security Checks
high
151108SUSE SLED15 / SLES15 Security Update : gupnp (SUSE-SU-2021:2153-1)NessusSuSE Local Security Checks
high
151022openSUSE 15 Security Update : gupnp (openSUSE-SU-2021:0917-1)NessusSuSE Local Security Checks
high
150880SUSE SLED12 / SLES12 Security Update : gupnp (SUSE-SU-2021:2080-1)NessusSuSE Local Security Checks
high
150845RHEL 8 : gupnp (RHSA-2021:2459)NessusRed Hat Local Security Checks
high
150830CentOS 8 : gupnp (CESA-2021:2363)NessusCentOS Local Security Checks
high
150812RHEL 8 : gupnp (RHSA-2021:2363)NessusRed Hat Local Security Checks
high
150794Oracle Linux 7 : gupnp (ELSA-2021-2417)NessusOracle Linux Local Security Checks
high
150789Scientific Linux Security Update : gupnp on SL7.x i686/x86_64 (2021:2417)NessusScientific Linux Local Security Checks
high
150777RHEL 7 : gupnp (RHSA-2021:2417)NessusRed Hat Local Security Checks
high
150775RHEL 8 : gupnp (RHSA-2021:2422)NessusRed Hat Local Security Checks
high
150499Oracle Linux 8 : gupnp (ELSA-2021-2363)NessusOracle Linux Local Security Checks
high
150130Ubuntu 20.04 LTS / 20.10 / 21.04 : GUPnP vulnerability (USN-4970-1)NessusUbuntu Local Security Checks
high