CVE-2021-32809

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

References

https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7889-rm5j-hpgg

https://lists.fedoraproject.org/archives/list/[email protected]/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/

https://lists.fedoraproject.org/archives/list/[email protected]/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/

https://lists.fedoraproject.org/archives/list/[email protected]/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/

https://www.oracle.com/security-alerts/cpuoct2021.html

Details

Source: MITRE

Published: 2021-08-12

Updated: 2021-10-20

Type: CWE-94

Risk Information

CVSS v2

Base Score: 3.5

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 6.8

Severity: LOW

CVSS v3

Base Score: 5.4

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.3

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:ckeditor:ckeditor:*:*:*:*:*:node.js:*:*

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
112947Drupal 8.9.x < 8.9.18 Third-Party Library VulnerabilityWeb Application ScanningComponent Vulnerability
medium
112946Drupal 9.1.x < 9.1.12 Third-Party Library VulnerabilityWeb Application ScanningComponent Vulnerability
medium
112945Drupal 9.2.x < 9.2.4 Third-Party Library VulnerabilityWeb Application ScanningComponent Vulnerability
medium
152533Drupal 8.9.x < 8.9.18 / 9.1.x < 9.1.12 / 9.2.x < 9.2.4 Multiple Vulnerabilities (SA-CORE-2021-005)NessusCGI abuses
medium