CVE-2021-3121

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in GoGo Protobuf before 1.3.2. plugin/unmarshal/unmarshal.go lacks certain index validation, aka the "skippy peanut butter" issue.

References

https://github.com/gogo/protobuf/compare/v1.3.1...v1.3.2

https://github.com/gogo/protobuf/commit/b03c65ea87cdc3521ede29f62fe3ce239267c1bc

https://lists.apache.org/thread.html/[email protected]%3Ccommits.pulsar.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccommits.pulsar.apache.org%3E

https://security.netapp.com/advisory/ntap-20210219-0006/

https://discuss.hashicorp.com/t/hcsec-2021-23-consul-exposed-to-denial-of-service-in-gogo-protobuf-dependency/29025

https://lists.apache.org/thread.html/[email protected]%3Cnotifications.skywalking.apache.org%3E

Details

Source: MITRE

Published: 2021-01-11

Updated: 2021-10-18

Type: CWE-129

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 8.6

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Impact Score: 4.7

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
153751Photon OS 3.0: Consul PHSA-2021-3.0-0303NessusPhotonOS Local Security Checks
high
153745Photon OS 4.0: Consul PHSA-2021-4.0-0105NessusPhotonOS Local Security Checks
high
152103RHEL 7 / 8 : OpenShift Container Platform 4.8.2 packages and (RHSA-2021:2437)NessusRed Hat Local Security Checks
high
148316RHEL 7 / 8 : OpenShift Container Platform 4.7.5 (RHSA-2021:1006)NessusRed Hat Local Security Checks
high
146810RHEL 7 / 8 : OpenShift Container Platform 4.7.0 packages (RHSA-2020:5634)NessusRed Hat Local Security Checks
high