CVE-2021-30937

high

Description

A memory corruption vulnerability was addressed with improved locking. This issue is fixed in macOS Big Sur 11.6.2, tvOS 15.2, macOS Monterey 12.1, Security Update 2021-008 Catalina, iOS 15.2 and iPadOS 15.2, watchOS 8.3. A malicious application may be able to execute arbitrary code with kernel privileges.

References

https://support.apple.com/en-us/HT212975

https://support.apple.com/en-us/HT212978

https://support.apple.com/en-us/HT212979

https://support.apple.com/en-us/HT212976

https://support.apple.com/en-us/HT212981

https://support.apple.com/en-us/HT212980

http://packetstormsecurity.com/files/165475/XNU-inm_merge-Heap-Use-After-Free.html

Details

Source: MITRE

Published: 2021-08-24

Updated: 2022-04-01

Type: CWE-787

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

CVSS v3

Base Score: 7.8

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH