CVE-2021-29986

high

Description

A suspected race condition when calling getaddrinfo led to memory corruption and a potentially exploitable crash. *Note: This issue only affected Linux operating systems. Other operating systems are unaffected.* This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.

References

https://www.mozilla.org/security/advisories/mfsa2021-34/

https://www.mozilla.org/security/advisories/mfsa2021-33/

https://www.mozilla.org/security/advisories/mfsa2021-36/

https://www.mozilla.org/security/advisories/mfsa2021-35/

https://bugzilla.mozilla.org/show_bug.cgi?id=1696138

https://security.gentoo.org/glsa/202202-03

Details

Source: MITRE

Published: 2021-08-17

Updated: 2022-03-16

Type: CWE-362

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH