CVE-2021-29970

high

Description

A malicious webpage could have triggered a use-after-free, memory corruption, and a potentially exploitable crash. *This bug could only be triggered when accessibility was enabled.*. This vulnerability affects Thunderbird < 78.12, Firefox ESR < 78.12, and Firefox < 90.

References

https://bugzilla.mozilla.org/show_bug.cgi?id=1709976

https://www.mozilla.org/security/advisories/mfsa2021-30/

https://www.mozilla.org/security/advisories/mfsa2021-29/

https://www.mozilla.org/security/advisories/mfsa2021-28/

https://security.gentoo.org/glsa/202202-03

https://security.gentoo.org/glsa/202208-14

Details

Source: MITRE

Published: 2021-08-05

Updated: 2022-08-10

Type: CWE-787

Risk Information

CVSS v2

Base Score: 5.1

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 4.9

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH