CVE-2021-29338

medium

Description

Integer Overflow in OpenJPEG v2.4.0 allows remote attackers to crash the application, causing a Denial of Service (DoS). This occurs when the attacker uses the command line option "-ImgDir" on a directory that contains 1048576 files.

References

https://github.com/uclouvain/openjpeg/issues/1338

https://lists.fedoraproject.org/archives/list/[email protected]/message/QB6AI7CWXWMEDZIQY4LQ6DMIEXMDOHUP/

https://lists.fedoraproject.org/archives/list/[email protected]/message/EZ54FGM2IGAP4AWSJ22JKHOPHCR3FGYU/

https://lists.debian.org/debian-lts-announce/2022/04/msg00006.html

Details

Source: MITRE

Published: 2021-04-14

Updated: 2022-04-19

Type: CWE-190

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM